Some NA Servers lack chat
Incident Report for Gota
Resolved
The chat servers are back to a functional state and should be smooth sailing from here on out.
Posted over 1 year ago. May 27, 2017 - 18:02 UTC
Identified
Some NA servers are lacking chat, we're working a fix as we speak.
Posted over 1 year ago. May 27, 2017 - 16:37 UTC