Sluggish load times
Incident Report for Gota
Resolved
This incident has been resolved.
Posted 11 months ago. Dec 02, 2017 - 15:12 UTC
Identified
Hey, we're aware of sluggish load times and are actively working to resolve the issue. If you receive a timeout, try again :) We'll keep you updated as we get more information
Posted 11 months ago. Dec 02, 2017 - 12:39 UTC