NA Servers Offline
Incident Report for Gota
Resolved
All servers seem to be back to normal and stable. We're marking this resolved! :)
Posted 21 days ago. Aug 03, 2019 - 15:48 UTC
Monitoring
Servers are starting to respond again, and players seem to be connecting fine. We'll keep this issue open until our provider makes a comment confirming this is fixed.

Thank you for hanging in there, and we apologize for the outage!
Posted 21 days ago. Aug 03, 2019 - 15:41 UTC
Investigating
Our North American provider is currently experiencing an outage, we're investigating and will provide more information as we get it! This isn't affecting other regions
Posted 21 days ago. Aug 03, 2019 - 15:34 UTC
This incident affected: Server Regions (North America).