Emails not delivering
Incident Report for Gota
Resolved
This incident has been resolved. Users should start receiving emails from this point on. We apologize for any inconvenience this has caused.
Posted about 2 years ago. May 10, 2017 - 20:58 UTC
Identified
We're aware our users have not been receiving emails from the forums. We've identified the issue and are working a solution.
Posted about 2 years ago. May 10, 2017 - 16:51 UTC